aboutsummaryrefslogtreecommitdiffstats
path: root/lampada/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-03-26 14:29:40 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2025-03-26 14:29:40 +0000
commit2211f324782cdc617b4b5ecd071178e372539fe4 (patch)
treea5ea5ce11d748424447dee23173d3cb8aec648ea /lampada/Cargo.toml
parent2f8671978e18c1e1e7834056ae674f32fbde3868 (diff)
downloadluz-2211f324782cdc617b4b5ecd071178e372539fe4.tar.gz
luz-2211f324782cdc617b4b5ecd071178e372539fe4.tar.bz2
luz-2211f324782cdc617b4b5ecd071178e372539fe4.zip
refactor: rename crates and move client logic to separate crate `filament`
Diffstat (limited to 'lampada/Cargo.toml')
-rw-r--r--lampada/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/lampada/Cargo.toml b/lampada/Cargo.toml
new file mode 100644
index 0000000..856fd7d
--- /dev/null
+++ b/lampada/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "lampada"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+futures = "0.3.31"
+luz = { version = "0.1.0", path = "../luz" }
+peanuts = { version = "0.1.0", path = "../../peanuts" }
+jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
+stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0203"] }
+tokio = "1.42.0"
+tokio-stream = "0.1.17"
+tokio-util = "0.7.13"
+tracing = "0.1.41"
+tracing-subscriber = "0.3.19"
+thiserror = "2.0.11"