aboutsummaryrefslogtreecommitdiffstats
path: root/jid/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-02-25 18:45:46 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2025-02-25 18:45:46 +0000
commit20fc4b196670c7f218abe87eba0fec43ed5068a6 (patch)
tree863d09f3bdbe23cd0045a777277a27be2743e242 /jid/Cargo.toml
parent65e908e36c2f9f9badc235de7a40e15836c77a8c (diff)
downloadluz-20fc4b196670c7f218abe87eba0fec43ed5068a6.tar.gz
luz-20fc4b196670c7f218abe87eba0fec43ed5068a6.tar.bz2
luz-20fc4b196670c7f218abe87eba0fec43ed5068a6.zip
feature gate sqlx for jid crate
Diffstat (limited to 'jid/Cargo.toml')
-rw-r--r--jid/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/jid/Cargo.toml b/jid/Cargo.toml
index 0d817c9..d5983ea 100644
--- a/jid/Cargo.toml
+++ b/jid/Cargo.toml
@@ -3,5 +3,8 @@ name = "jid"
version = "0.1.0"
edition = "2021"
+[features]
+sqlx = ["dep:sqlx"]
+
[dependencies]
-sqlx = { version = "0.8.3", features = ["sqlite"] }
+sqlx = { version = "0.8.3", features = ["sqlite"], optional = true }