summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@blos.sm>2023-06-19 19:23:54 +0100
committerLibravatar cel 🌸 <cel@blos.sm>2023-06-19 19:23:54 +0100
commit6a5e39c60ad74c1cba84daa7c845c8f0237a5d28 (patch)
tree7115e5dc2679bc053acb9b28fed41d3175ed2817 /Cargo.toml
parentabc3ffa7363ebd30101e15db7e02a7d44f323df9 (diff)
downloadluz-6a5e39c60ad74c1cba84daa7c845c8f0237a5d28.tar.gz
luz-6a5e39c60ad74c1cba84daa7c845c8f0237a5d28.tar.bz2
luz-6a5e39c60ad74c1cba84daa7c845c8f0237a5d28.zip
implement starttls
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 12a7f4e..472bbf7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,6 +7,9 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-quick-xml = { version = "0.29.0", features = ["async-tokio"] }
+async-trait = "0.1.68"
+quick-xml = { version = "0.29.0", features = ["async-tokio", "serialize"] }
+serde = { version = "1.0.164", features = ["derive"] }
tokio = { version = "1.28", features = ["full"] }
+tokio-native-tls = "0.3.1"
trust-dns-resolver = "0.22.0"