aboutsummaryrefslogtreecommitdiffstats
path: root/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Christian Murphy <christian.murphy.42@gmail.com>2023-04-01 03:09:26 -0700
committerLibravatar GitHub <noreply@github.com>2023-04-01 12:09:26 +0200
commitb3a921c761309ae00a51fe348d8a43adbc54b518 (patch)
tree4e3b50a46d35cd3ce768746c12088fadf36f43fc /fuzz/Cargo.toml
parent2498e31eecead798efc649502bbf5f86feaa94be (diff)
downloadmarkdown-rs-b3a921c761309ae00a51fe348d8a43adbc54b518.tar.gz
markdown-rs-b3a921c761309ae00a51fe348d8a43adbc54b518.tar.bz2
markdown-rs-b3a921c761309ae00a51fe348d8a43adbc54b518.zip
Add `honggfuzz` as an alternative fuzzer
Closes GH-55. Reviewed-by: Titus Wormer <tituswormer@gmail.com>
Diffstat (limited to 'fuzz/Cargo.toml')
-rw-r--r--fuzz/Cargo.toml11
1 files changed, 9 insertions, 2 deletions
diff --git a/fuzz/Cargo.toml b/fuzz/Cargo.toml
index c8f9850..6a50fd2 100644
--- a/fuzz/Cargo.toml
+++ b/fuzz/Cargo.toml
@@ -10,6 +10,7 @@ cargo-fuzz = true
[dependencies]
libfuzzer-sys = "0.4"
+honggfuzz = "0.5"
[dependencies.markdown]
path = ".."
@@ -19,7 +20,13 @@ path = ".."
members = ["."]
[[bin]]
-name = "markdown"
-path = "fuzz_targets/markdown.rs"
+name = "markdown_libfuzz"
+path = "fuzz_targets/markdown_libfuzz.rs"
test = false
doc = false
+
+[[bin]]
+name = "markdown_honggfuzz"
+path = "fuzz_targets/markdown_honggfuzz.rs"
+test = false
+doc = false \ No newline at end of file