aboutsummaryrefslogtreecommitdiffstats
path: root/askama_warp/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Bjørn Madsen <bm@aeons.dk>2020-01-29 09:32:39 +0100
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2020-01-29 11:22:47 +0100
commit91c2bbf80468c12d0663330cff185f1d7680c91e (patch)
tree9cadabbc819ffeffb5ff02b1605cb5d614425b47 /askama_warp/Cargo.toml
parente507c6faf61488cbce23a16eb823816f45130019 (diff)
downloadaskama-91c2bbf80468c12d0663330cff185f1d7680c91e.tar.gz
askama-91c2bbf80468c12d0663330cff185f1d7680c91e.tar.bz2
askama-91c2bbf80468c12d0663330cff185f1d7680c91e.zip
Add support for warp
Diffstat (limited to 'askama_warp/Cargo.toml')
-rw-r--r--askama_warp/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/askama_warp/Cargo.toml b/askama_warp/Cargo.toml
new file mode 100644
index 0000000..557ab46
--- /dev/null
+++ b/askama_warp/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "askama_warp"
+version = "0.9.0"
+authors = ["Dirkjan Ochtman <dirkjan@ochtman.nl>", "Bjørn Madsen <bm@aeons.dk>"]
+description = "Warp integration for Askama templates"
+documentation = "https://docs.rs/askama"
+keywords = ["markup", "template", "jinja2", "html"]
+categories = ["template-engine"]
+homepage = "https://github.com/djc/askama"
+repository = "https://github.com/djc/askama"
+license = "MIT OR Apache-2.0"
+workspace = ".."
+edition = "2018"
+
+[dependencies]
+askama = { version = "0.9.0", path = "../askama", features = ["with-warp", "mime", "mime_guess"] }
+warp = "0.2"
+
+[dev-dependencies]
+tokio-test = "0.2"
+tokio = { version = "0.2", features = ["macros"] }