aboutsummaryrefslogtreecommitdiffstats
path: root/askama_rocket/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar René Kijewski <kijewski@library.vetmed.fu-berlin.de>2022-06-16 07:44:06 +0200
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2022-06-16 08:44:28 +0200
commit5cdffd6e0e9eb0a408cec6e5a143231e139970fe (patch)
treea2c803de0fac66fa07f217878479fdb87143cb93 /askama_rocket/Cargo.toml
parentd4c13f5b4367fd3ca57fc14fdcf1d01694060c7a (diff)
downloadaskama-5cdffd6e0e9eb0a408cec6e5a143231e139970fe.tar.gz
askama-5cdffd6e0e9eb0a408cec6e5a143231e139970fe.tar.bz2
askama-5cdffd6e0e9eb0a408cec6e5a143231e139970fe.zip
Update to Rocket 0.5
Though Rocket 0.5 still only a release candidate, Rocket 0.4 severely outdated, and depends on a bunch of crates with active security advisories. Rocket 0.5 updates its dependencies to fixes versions. Also Rocket 0.4 needs a nightly Rust, which caused multiple problems.
Diffstat (limited to 'askama_rocket/Cargo.toml')
-rw-r--r--askama_rocket/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/askama_rocket/Cargo.toml b/askama_rocket/Cargo.toml
index bdace04..53a0953 100644
--- a/askama_rocket/Cargo.toml
+++ b/askama_rocket/Cargo.toml
@@ -14,7 +14,10 @@ edition = "2018"
[dependencies]
askama = { version = "0.11.2", path = "../askama", default-features = false, features = ["with-rocket", "mime", "mime_guess"] }
-rocket = { version = "0.4", default-features = false }
+rocket = { version = "0.5.0-rc.2", default-features = false }
+
+[dev-dependencies]
+futures-lite = "1.12.0"
[features]
default = ["askama/default"]