aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-02-25 18:08:20 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2025-02-25 18:08:20 +0000
commitfe389c38ca2ff23e3f2bd2305b455e4d551a9ccc (patch)
tree11fe43131016adc290a4bc381dd5ede34679dc5b /Cargo.toml
parentbbb1452905a3f59e178031bb3eeca4d963e50394 (diff)
downloadpeanuts-fe389c38ca2ff23e3f2bd2305b455e4d551a9ccc.tar.gz
peanuts-fe389c38ca2ff23e3f2bd2305b455e4d551a9ccc.tar.bz2
peanuts-fe389c38ca2ff23e3f2bd2305b455e4d551a9ccc.zip
implement proper errors with thiserror
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 40e23bc..25f29a5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,5 +11,6 @@ circular = { version = "0.3.0", path = "../circular" }
futures = "0.3.30"
futures-util = { version = "0.3.31", features = ["sink"] }
nom = "7.1.3"
+thiserror = "2.0.11"
tokio = { version = "1.36.0", features = ["io-util", "net", "io-std", "full"] }
tracing = "0.1.41"