diff options
author | 2025-04-13 10:38:58 +0100 | |
---|---|---|
committer | 2025-04-13 10:38:58 +0100 | |
commit | 1c55b582a8e874b5dc776950c92a1ecf622d03fe (patch) | |
tree | cc3f21fa0a8d1fa6ea32ab0c3fd391c14c3ba29f /Cargo.toml | |
parent | c658ab440f8e69ac406b18732dbf276c084926b6 (diff) | |
download | peanuts-1c55b582a8e874b5dc776950c92a1ecf622d03fe.tar.gz peanuts-1c55b582a8e874b5dc776950c92a1ecf622d03fe.tar.bz2 peanuts-1c55b582a8e874b5dc776950c92a1ecf622d03fe.zip |
feat: websocket-framed reader and writer
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -13,9 +13,13 @@ futures = "0.3.30" futures-util = { version = "0.3.31", features = ["sink"] } nom = "7.1.3" thiserror = "2.0.11" -tokio = { version = "1.36.0", features = ["io-util"] } +tokio = { version = "1.36.0", features = ["io-util", "sync"] } tracing = "0.1.41" [dev-dependencies] tokio = { version = "1.36.0", features = ["io-util", "macros", "rt-multi-thread", "io-std"] } +[target.'cfg(target_arch = "wasm32")'.dependencies] +wasm-bindgen = "0.2" +js-sys = "0.3" +web-sys = { version = "0.3", features = ["WebSocket", "MessageEvent", "Blob"] } |