aboutsummaryrefslogtreecommitdiffstats
path: root/luz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'luz/Cargo.toml')
-rw-r--r--luz/Cargo.toml46
1 files changed, 34 insertions, 12 deletions
diff --git a/luz/Cargo.toml b/luz/Cargo.toml
index 08a0d6c..c1c1511 100644
--- a/luz/Cargo.toml
+++ b/luz/Cargo.toml
@@ -1,20 +1,42 @@
[package]
name = "luz"
+authors = ["cel <cel@bunny.garden>"]
version = "0.1.0"
edition = "2021"
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
[dependencies]
-futures = "0.3.31"
-jabber = { version = "0.1.0", path = "../jabber" }
+async-recursion = "1.0.4"
+async-trait = "0.1.68"
+lazy_static = "1.4.0"
+nanoid = "0.4.0"
+# TODO: remove unneeded features and dependencies
+rsasl = { version = "2.0.1", default_features = false, features = [
+ "provider_base64",
+ "plain",
+ "config_builder",
+ "scram-sha-1",
+] }
+tokio = { version = "1.28", features = ["full"] }
+tokio-native-tls = "0.3.1"
+tracing = "0.1.40"
+trust-dns-resolver = "0.22.0"
+try_map = "0.3.1"
+stanza = { version = "0.1.0", path = "../stanza" }
peanuts = { version = "0.1.0", path = "../../peanuts" }
-jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
-sqlx = { version = "0.8.3", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
-stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0203"] }
-tokio = "1.42.0"
-tokio-stream = "0.1.17"
-tokio-util = "0.7.13"
-tracing = "0.1.41"
-tracing-subscriber = "0.3.19"
-uuid = { version = "1.13.1", features = ["v4"] }
+jid = { version = "0.1.0", path = "../jid" }
+futures = "0.3.31"
+take_mut = "0.2.2"
+pin-project-lite = "0.2.15"
+pin-project = "1.1.7"
thiserror = "2.0.11"
-chrono = "0.4.40"
+
+[dev-dependencies]
+test-log = { version = "0.2", features = ["trace"] }
+env_logger = "*"
+tracing-subscriber = { version = "0.3", default-features = false, features = [
+ "env-filter",
+ "fmt",
+] }
+stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0199"] }