aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'filamento/Cargo.toml')
-rw-r--r--filamento/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
index e9be687..3530ab9 100644
--- a/filamento/Cargo.toml
+++ b/filamento/Cargo.toml
@@ -8,13 +8,16 @@ futures = "0.3.31"
lampada = { version = "0.1.0", path = "../lampada" }
tokio = "1.42.0"
thiserror = "2.0.11"
-stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172"] }
+stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128"] }
sqlx = { version = "0.8.3", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
# TODO: re-export jid?
jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
uuid = { version = "1.13.1", features = ["v4"] }
tracing = "0.1.41"
chrono = "0.4.40"
+sha2 = "0.10.8"
+sha3 = "0.10.8"
+base64 = "0.22.1"
[dev-dependencies]
tracing-subscriber = "0.3.19"