aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'filamento/Cargo.toml')
-rw-r--r--filamento/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
index 1c28c39..91b7e91 100644
--- a/filamento/Cargo.toml
+++ b/filamento/Cargo.toml
@@ -8,7 +8,7 @@ futures = "0.3.31"
lampada = { version = "0.1.0", path = "../lampada" }
tokio = "1.42.0"
thiserror = "2.0.11"
-stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128", "xep_0115"] }
+stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128", "xep_0115", "xep_0084"] }
sqlx = { version = "0.8.3", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
# TODO: re-export jid?
jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
@@ -19,10 +19,12 @@ sha2 = "0.10.8"
sha3 = "0.10.8"
base64 = "0.22.1"
sha1 = "0.10.6"
+image = "0.25.6"
+hex = "0.4.3"
[dev-dependencies]
tracing-subscriber = "0.3.19"
-peanuts = { version = "0.1.0", path = "../../peanuts" }
+peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
[[example]]
name = "example"