aboutsummaryrefslogtreecommitdiffstats
path: root/jabber/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-01-12 21:19:07 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2025-01-12 21:19:07 +0000
commite6c97ab82880ad4cd12b05bc1c8f2a0a3413735c (patch)
tree372426b3286bd9dca98b328536153df61cf8a74c /jabber/Cargo.toml
parent0e5f09b2bd05690f3d28f7076629031fcc2cc6e6 (diff)
downloadluz-e6c97ab82880ad4cd12b05bc1c8f2a0a3413735c.tar.gz
luz-e6c97ab82880ad4cd12b05bc1c8f2a0a3413735c.tar.bz2
luz-e6c97ab82880ad4cd12b05bc1c8f2a0a3413735c.zip
implement stream splitting and closing
Diffstat (limited to 'jabber/Cargo.toml')
-rw-r--r--jabber/Cargo.toml12
1 files changed, 10 insertions, 2 deletions
diff --git a/jabber/Cargo.toml b/jabber/Cargo.toml
index 68dddd9..d070838 100644
--- a/jabber/Cargo.toml
+++ b/jabber/Cargo.toml
@@ -12,7 +12,12 @@ async-trait = "0.1.68"
lazy_static = "1.4.0"
nanoid = "0.4.0"
# TODO: remove unneeded features
-rsasl = { version = "2.0.1", path = "../../rsasl", default_features = false, features = ["provider_base64", "plain", "config_builder", "scram-sha-1"] }
+rsasl = { version = "2.0.1", default_features = false, features = [
+ "provider_base64",
+ "plain",
+ "config_builder",
+ "scram-sha-1",
+] }
tokio = { version = "1.28", features = ["full"] }
tokio-native-tls = "0.3.1"
tracing = "0.1.40"
@@ -29,4 +34,7 @@ pin-project = "1.1.7"
[dev-dependencies]
test-log = { version = "0.2", features = ["trace"] }
env_logger = "*"
-tracing-subscriber = {version = "0.3", default-features = false, features = ["env-filter", "fmt"]}
+tracing-subscriber = { version = "0.3", default-features = false, features = [
+ "env-filter",
+ "fmt",
+] }