aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-04-03 11:06:00 +0100
committerLibravatar cel 🌸 <cel@bunny.garden>2025-04-03 11:06:10 +0100
commitbf00184a09418750caeb488d8d71f9dc7afd7aff (patch)
tree0f0b7f118c86e7306db50a38494320b5a8316f0e /filamento/Cargo.toml
parent236c8a4ba8ee285decf951f73a8cb1e389414e8e (diff)
downloadluz-bf00184a09418750caeb488d8d71f9dc7afd7aff.tar.gz
luz-bf00184a09418750caeb488d8d71f9dc7afd7aff.tar.bz2
luz-bf00184a09418750caeb488d8d71f9dc7afd7aff.zip
feat(filamento): caps 1.0 helper functions & tests
Diffstat (limited to 'filamento/Cargo.toml')
-rw-r--r--filamento/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
index 3530ab9..1c28c39 100644
--- a/filamento/Cargo.toml
+++ b/filamento/Cargo.toml
@@ -8,7 +8,7 @@ futures = "0.3.31"
lampada = { version = "0.1.0", path = "../lampada" }
tokio = "1.42.0"
thiserror = "2.0.11"
-stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128"] }
+stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128", "xep_0115"] }
sqlx = { version = "0.8.3", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
# TODO: re-export jid?
jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
@@ -18,9 +18,11 @@ chrono = "0.4.40"
sha2 = "0.10.8"
sha3 = "0.10.8"
base64 = "0.22.1"
+sha1 = "0.10.6"
[dev-dependencies]
tracing-subscriber = "0.3.19"
+peanuts = { version = "0.1.0", path = "../../peanuts" }
[[example]]
name = "example"