aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-03-26 14:29:40 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2025-03-26 14:29:40 +0000
commit2211f324782cdc617b4b5ecd071178e372539fe4 (patch)
treea5ea5ce11d748424447dee23173d3cb8aec648ea /filamento/Cargo.toml
parent2f8671978e18c1e1e7834056ae674f32fbde3868 (diff)
downloadluz-2211f324782cdc617b4b5ecd071178e372539fe4.tar.gz
luz-2211f324782cdc617b4b5ecd071178e372539fe4.tar.bz2
luz-2211f324782cdc617b4b5ecd071178e372539fe4.zip
refactor: rename crates and move client logic to separate crate `filament`
Diffstat (limited to 'filamento/Cargo.toml')
-rw-r--r--filamento/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
new file mode 100644
index 0000000..e25024a
--- /dev/null
+++ b/filamento/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "filamento"
+version = "0.1.0"
+edition = "2024"
+
+[dependencies]
+futures = "0.3.31"
+lampada = { version = "0.1.0", path = "../lampada" }
+tokio = "1.42.0"
+thiserror = "2.0.11"
+stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0203"] }
+sqlx = { version = "0.8.3", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
+# TODO: re-export jid?
+jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
+uuid = { version = "1.13.1", features = ["v4"] }
+tracing = "0.1.41"
+chrono = "0.4.40"