aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2024-11-29 02:11:02 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2024-11-29 02:11:02 +0000
commitb6593389069903cc4c85e40611296d8a240f718d (patch)
treeae4df92ea45cce5e5b904041a925263e8d629274 /Cargo.toml
parent2dcbc9e1f4339993dd47b2659770a9cf4855b02d (diff)
downloadluz-b6593389069903cc4c85e40611296d8a240f718d.tar.gz
luz-b6593389069903cc4c85e40611296d8a240f718d.tar.bz2
luz-b6593389069903cc4c85e40611296d8a240f718d.zip
implement sasl kinda
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f136e90..326e45e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,7 @@ async-trait = "0.1.68"
lazy_static = "1.4.0"
nanoid = "0.4.0"
# TODO: remove unneeded features
-rsasl = { version = "2", default_features = true, features = ["provider_base64", "plain", "config_builder"] }
+rsasl = { version = "2.0.1", default_features = false, features = ["provider_base64", "plain", "config_builder", "scram-sha-1"] }
tokio = { version = "1.28", features = ["full"] }
tokio-native-tls = "0.3.1"
tracing = "0.1.40"