aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2024-11-23 22:39:44 +0000
committerLibravatar cel 🌸 <cel@bunny.garden>2024-11-23 22:39:44 +0000
commit40024d2dadba9e70edb2f3448204565ce3f68ab7 (patch)
tree3f08b61debf936c513f300c845d8a1cb29edd7c8 /Cargo.toml
parent9f2546f6dadd916b0e7fc5be51e92d682ef2487b (diff)
downloadluz-40024d2dadba9e70edb2f3448204565ce3f68ab7.tar.gz
luz-40024d2dadba9e70edb2f3448204565ce3f68ab7.tar.bz2
luz-40024d2dadba9e70edb2f3448204565ce3f68ab7.zip
switch to using peanuts for xml
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ea47616..f136e90 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,16 +11,14 @@ async-recursion = "1.0.4"
async-trait = "0.1.68"
lazy_static = "1.4.0"
nanoid = "0.4.0"
-quick-xml = { git = "https://github.com/tafia/quick-xml.git", features = ["async-tokio", "serialize"] }
# TODO: remove unneeded features
rsasl = { version = "2", default_features = true, features = ["provider_base64", "plain", "config_builder"] }
-serde = "1.0.180"
-serde_with = "3.4.0"
tokio = { version = "1.28", features = ["full"] }
tokio-native-tls = "0.3.1"
tracing = "0.1.40"
trust-dns-resolver = "0.22.0"
try_map = "0.3.1"
+peanuts = { version = "0.1.0", path = "../peanuts" }
[dev-dependencies]
test-log = { version = "0.2", features = ["trace"] }