aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'testing/Cargo.toml')
-rw-r--r--testing/Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index 6223673..7c93783 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -5,13 +5,14 @@ authors = ["Dirkjan Ochtman <dirkjan@ochtman.nl>"]
workspace = ".."
[features]
-default = []
-nightly = ["rocket", "rocket_codegen", "askama/with-rocket"]
+default = ["actix"]
+with-rocket = ["rocket", "rocket_codegen", "askama/with-rocket"]
+actix = ["actix-web", "bytes", "askama/with-actix-web"]
[dependencies]
-actix-web = "0.7"
-askama = { path = "../askama", version = "*", features = ["with-actix-web", "with-iron", "serde-json"] }
-bytes = "0.4"
+actix-web = { version = "0.7", optional = true }
+askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+bytes = { version = "0.4", optional = true }
criterion = "0.2"
iron = "0.6"
rocket = { version = "0.3", optional = true }
@@ -19,7 +20,7 @@ rocket_codegen = { version = "0.3", optional = true }
serde_json = "1.0"
[build-dependencies]
-askama = { path = "../askama", version = "*", features = ["with-actix-web", "with-iron", "serde-json"] }
+askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
[[bench]]
name = "all"