aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2018-06-28 17:01:12 +0200
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2018-06-28 17:01:12 +0200
commit970e3ecfbdf9e4e4c4faacdb87efa656e812398a (patch)
tree053c82e655441354004f4962d4d02e1674b7d8e4 /testing/Cargo.toml
parentcb4fcbf379734345305065c2cce68046724a3408 (diff)
downloadaskama-970e3ecfbdf9e4e4c4faacdb87efa656e812398a.tar.gz
askama-970e3ecfbdf9e4e4c4faacdb87efa656e812398a.tar.bz2
askama-970e3ecfbdf9e4e4c4faacdb87efa656e812398a.zip
Add benchmarks to the Askama repo
Diffstat (limited to 'testing/Cargo.toml')
-rw-r--r--testing/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index 06fdf56..ff67e2e 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -10,6 +10,7 @@ nightly = ["rocket", "rocket_codegen", "askama/with-rocket"]
[dependencies]
askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+criterion = "0.2"
iron = "0.6"
rocket = { version = "0.3", optional = true }
rocket_codegen = { version = "0.3", optional = true }
@@ -17,3 +18,7 @@ serde_json = "1.0"
[build-dependencies]
askama = { path = "../askama", version = "*", features = ["with-iron", "serde-json"] }
+
+[[bench]]
+name = "all"
+harness = false