aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar DCjanus <DCjanus@dcjanus.com>2020-01-11 23:39:17 +0800
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2020-01-11 17:43:55 +0100
commit6b11df9e92c7414968d71c65249d273183ecd716 (patch)
tree7ebe693dd95d87ed7c1bc0a4976a7bb40e8dab9b /testing/Cargo.toml
parentcef055108de6c51c1423cd6a8919730ef01f64a3 (diff)
downloadaskama-6b11df9e92c7414968d71c65249d273183ecd716.tar.gz
askama-6b11df9e92c7414968d71c65249d273183ecd716.tar.bz2
askama-6b11df9e92c7414968d71c65249d273183ecd716.zip
upgrade dependencies(actix-web 0.7 -> 2)
Diffstat (limited to 'testing/Cargo.toml')
-rw-r--r--testing/Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index 73e0a8a..4aa80fe 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -6,7 +6,7 @@ workspace = ".."
edition = "2018"
[features]
-actix = ["actix-web", "bytes", "askama/with-actix-web"]
+actix = ["actix-web", "actix-rt", "bytes", "askama/with-actix-web", "futures"]
default = []
full = ["actix", "with-iron", "serde-json", "with-gotham"]
serde-json = ["serde_json", "askama/serde-json"]
@@ -15,9 +15,11 @@ with-iron = ["iron", "askama/with-iron"]
with-gotham = ["gotham", "askama/with-gotham", "mime", "hyper"]
[dependencies]
-actix-web = { version = "0.7", optional = true }
+actix-web = { version = "2", optional = true }
+actix-rt = { version = "1", optional = true }
+futures = { version = "0.3", optional = true }
askama = { path = "../askama", version = "*" }
-bytes = { version = "0.4", optional = true }
+bytes = { version = "0.5", optional = true }
iron = { version = "0.6", optional = true }
rocket = { version = "0.4", optional = true }
serde_json = { version = "1.0", optional = true }