aboutsummaryrefslogtreecommitdiffstats
path: root/askama_shared/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Konrad Borowski <konrad@borowski.pw>2020-11-21 12:10:50 +0100
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2020-11-21 12:54:18 +0100
commit8603298dc8c8c80d95199e1f42ec6951264322f1 (patch)
treed03a9c1f203e13283e0bfd6e65f6027170ec8756 /askama_shared/Cargo.toml
parentc024db6a3a007e3d592d41001533df851343ed45 (diff)
downloadaskama-8603298dc8c8c80d95199e1f42ec6951264322f1.tar.gz
askama-8603298dc8c8c80d95199e1f42ec6951264322f1.tar.bz2
askama-8603298dc8c8c80d95199e1f42ec6951264322f1.zip
Disable nom default features
This removes unnecessary lexical feature reducing amount of crates Askama depends on.
Diffstat (limited to 'askama_shared/Cargo.toml')
-rw-r--r--askama_shared/Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/askama_shared/Cargo.toml b/askama_shared/Cargo.toml
index 2da9df6..19946e7 100644
--- a/askama_shared/Cargo.toml
+++ b/askama_shared/Cargo.toml
@@ -19,9 +19,7 @@ yaml = ["serde", "serde_yaml"]
[dependencies]
askama_escape = { version = "0.10", path = "../askama_escape" }
humansize = { version = "1.1.0", optional = true }
-# default for features for nom don't work result in linker errors:
-# https://github.com/rust-lang/rust/issues/62146
-nom = { version = "6", features = ["std"] }
+nom = { version = "6", features = ["std"], default-features = false }
num-traits = { version = "0.2.6", optional = true }
proc-macro2 = "1"
quote = "1"