aboutsummaryrefslogtreecommitdiffstats
path: root/askama_parser/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar manunio <max.manu.nair@gmail.com>2023-09-11 18:21:59 +0530
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2023-09-13 14:48:08 +0200
commit8f3140a33fa76be248883539d8ecb51b7a7700e2 (patch)
tree4c829d14f392a79e04f965a200a2951d7c0d8110 /askama_parser/fuzz/Cargo.toml
parent2e8e42af457732f25d00b2c5d42695353d301804 (diff)
downloadaskama-8f3140a33fa76be248883539d8ecb51b7a7700e2.tar.gz
askama-8f3140a33fa76be248883539d8ecb51b7a7700e2.tar.bz2
askama-8f3140a33fa76be248883539d8ecb51b7a7700e2.zip
fuzz: Add fuzz for askama_parser
Diffstat (limited to 'askama_parser/fuzz/Cargo.toml')
-rw-r--r--askama_parser/fuzz/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/askama_parser/fuzz/Cargo.toml b/askama_parser/fuzz/Cargo.toml
new file mode 100644
index 0000000..3190e5a
--- /dev/null
+++ b/askama_parser/fuzz/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "askama_parser-fuzz"
+version = "0.0.0"
+publish = false
+edition = "2021"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+libfuzzer-sys = "0.4"
+
+[dependencies.askama_parser]
+path = ".."
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[profile.release]
+debug = 1
+
+[[bin]]
+name = "fuzz_parser"
+path = "fuzz_targets/fuzz_parser.rs"
+test = false
+doc = false