aboutsummaryrefslogtreecommitdiffstats
path: root/askama_actix/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2021-12-21 23:17:14 +0100
committerLibravatar Dirkjan Ochtman <dirkjan@ochtman.nl>2022-01-04 21:30:15 +0100
commit42d80ad6cdb1a4ff9ff8fcc088b25d5f7b66a393 (patch)
tree7faca2dc4d177a109e4c7849a1c1f5f24af72999 /askama_actix/Cargo.toml
parent6c8c0d63065608ca079110fe20721b7c4d8594f8 (diff)
downloadaskama-42d80ad6cdb1a4ff9ff8fcc088b25d5f7b66a393.tar.gz
askama-42d80ad6cdb1a4ff9ff8fcc088b25d5f7b66a393.tar.bz2
askama-42d80ad6cdb1a4ff9ff8fcc088b25d5f7b66a393.zip
askama_actix: revert to actix-web v3 for release
Diffstat (limited to 'askama_actix/Cargo.toml')
-rw-r--r--askama_actix/Cargo.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/askama_actix/Cargo.toml b/askama_actix/Cargo.toml
index 06fd2b3..14e996b 100644
--- a/askama_actix/Cargo.toml
+++ b/askama_actix/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "askama_actix"
-version = "0.11.1"
+version = "0.12.0"
description = "Actix-Web integration for Askama templates"
documentation = "https://docs.rs/askama"
keywords = ["markup", "template", "jinja2", "html"]
@@ -13,11 +13,10 @@ readme = "README.md"
edition = "2018"
[dependencies]
-actix-web = { version = "4.0.0-beta.14", default-features = false }
+actix-web = { version = "3", default-features = false }
askama = { version = "0.11.0", path = "../askama", default-features = false, features = ["with-actix-web", "mime", "mime_guess"] }
-bytes = { version = "1" }
+bytes = { version = "0.5" }
futures-util = { version = "0.3" }
[dev-dependencies]
-actix-rt = { version = "2", default-features = false }
-actix-test = "0.1.0-beta.8"
+actix-rt = { version = "1", default-features = false }