summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@blos.sm>2024-11-13 20:00:15 +0000
committerLibravatar cel 🌸 <cel@blos.sm>2024-11-13 20:00:15 +0000
commitb7a2265e9b29d8fa09f84f5213ef7f8ed3045ca6 (patch)
tree280a31f5887aafdaa200a2b5f4c05ff106d9e365 /Cargo.toml
downloadcritch-b7a2265e9b29d8fa09f84f5213ef7f8ed3045ca6.tar.gz
critch-b7a2265e9b29d8fa09f84f5213ef7f8ed3045ca6.tar.bz2
critch-b7a2265e9b29d8fa09f84f5213ef7f8ed3045ca6.zip
initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..8980e23
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "critch"
+authors = ["cel <cel@bunny.garden>"]
+version = "0.1.0"
+edition = "2021"
+
+build = "src/build.rs"
+
+[build-dependencies]
+ructe = { version = "0.17.2", features = ["sass", "mime03"] }
+
+[dependencies]
+poem = { version = "3.1.3", features = ["session"] }
+serde = "1.0.215"
+sqlx = { version = "0.8.2", features = ["uuid", "postgres", "runtime-tokio"] }
+tokio = { version = "1.41.1", features = ["full"] }
+toml = { version = "0.8.19", features = ["parse"] }
+uuid = "1.11.0"