aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..15762fb
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs }:
+
+with lib;
+
+let
+ cfg = config.blossom;
+in
+{
+ options.blossom = {
+ enable = mkEnableOption "blossom";
+ }
+
+ config =
+}
+pkgs.rustPlatform.buildRustPackage rec {
+ pname = "blossom";
+ version = "1.0.0";
+
+ cargoLock.lockFile = /etc/nixos/blossom/Cargo.lock;
+
+ src = pkgs.lib.cleanSource ./.;
+}
+