diff options
author | cel 🌸 <cel@blos.sm> | 2024-01-30 16:16:05 +0000 |
---|---|---|
committer | cel 🌸 <cel@blos.sm> | 2024-01-30 16:16:05 +0000 |
commit | f00159f53b3774601500ec65345791311ff6efa1 (patch) | |
tree | cc65a487e71a056126e1935108a494c7851863f9 /Cargo.toml | |
parent | 8c03d9a53f4bc2f70fb5c1e0487bc74fe0137fcb (diff) | |
download | blossom-f00159f53b3774601500ec65345791311ff6efa1.tar.gz blossom-f00159f53b3774601500ec65345791311ff6efa1.tar.bz2 blossom-f00159f53b3774601500ec65345791311ff6efa1.zip |
migrate to poem and askama
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 8 insertions, 4 deletions
@@ -1,19 +1,16 @@ [package] name = "blossom" -version = "1.0.0" +version = "2.0.0" edition = "2021" # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [dependencies] -rocket = { version = "0.5.0-rc.2", features = ["json"] } # sqlx = { version = "0.5", default-features = false, features = ["macros", "offline", "migrate"] } -# rocket_db_pools = { version = "0.1.0-rc.2", features = ["sqlx_sqlite"] } reqwest = { version = "0.11", features = ["json"] } mastodon-async = { git = "https://sectorinf.com/cel/mastodon-async.git" } tokio = { version = "1", features = ["full"] } serde = { version = "1.0", features = ["derive"] } -rocket_dyn_templates = { version = "0.1.0-rc.2", features = ["tera"] } listenbrainz = "0.7" chrono = "0.4.23" serde_json = "1.0.97" @@ -24,3 +21,10 @@ async-trait = "0.1.68" toml = "0.7.4" tokio-stream = { version = "0.1.14", features = ["fs"] } atom_syndication = "0.12.1" +fluent = "0.16.0" +poem = { version = "2.0.0", features = ["embed"] } +askama = { git = "https://bunny.garden/forks/askama.git", features = ["with-poem"] } +askama_poem = { git = "https://bunny.garden/forks/askama.git" } +rust-embed = "8.2.0" +rand = "0.8.5" +thiserror = "1.0.56" |