aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@blos.sm>2023-01-15 21:43:21 +0000
committerLibravatar cel 🌸 <cel@blos.sm>2023-01-15 21:43:21 +0000
commit1280b8d6a2a3f2a02179a1e51aef1891a04cc8dd (patch)
treea5abd1d1855d2d1123586d50e58567096c7dd695 /Cargo.toml
parent4a860896c21220b2b8b22da4a5d2f8794c90253a (diff)
downloadblossom-1280b8d6a2a3f2a02179a1e51aef1891a04cc8dd.tar.gz
blossom-1280b8d6a2a3f2a02179a1e51aef1891a04cc8dd.tar.bz2
blossom-1280b8d6a2a3f2a02179a1e51aef1891a04cc8dd.zip
set up rocket server
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..c584041
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "site"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+rocket = { version = "0.5.0-rc.2", features = ["json"] }
+reqwest = { version = "0.11", features = ["json"] }
+tokio = { version = "1", features = ["full"] }
+rocket_dyn_templates = { version = "0.1.0-rc.2", features = ["tera"] }