diff options
Diffstat (limited to '')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -13,9 +13,13 @@ futures = "0.3.30" futures-util = { version = "0.3.31", features = ["sink"] } nom = "7.1.3" thiserror = "2.0.11" -tokio = { version = "1.36.0", features = ["io-util"] } +tokio = { version = "1.36.0", features = ["io-util", "sync"] } tracing = "0.1.41" [dev-dependencies] tokio = { version = "1.36.0", features = ["io-util", "macros", "rt-multi-thread", "io-std"] } +[target.'cfg(target_arch = "wasm32")'.dependencies] +wasm-bindgen = "0.2" +js-sys = "0.3" +web-sys = { version = "0.3", features = ["WebSocket", "MessageEvent", "Blob"] } |