aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Cargo.toml12
1 files changed, 10 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index efa03c1..334f0f1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,10 +8,18 @@ edition = "2021"
[dependencies]
pin-project = "1"
async-recursion = "1.1.1"
-circular = { version = "0.3.0", path = "../circular" }
+circular = { version = "0.3.0", git = "https://bunny.garden/forks/circular" }
futures = "0.3.30"
futures-util = { version = "0.3.31", features = ["sink"] }
nom = "7.1.3"
thiserror = "2.0.11"
-tokio = { version = "1.36.0", features = ["io-util", "net", "io-std", "full"] }
+tokio = { version = "1.36.0", features = ["io-util", "sync"] }
tracing = "0.1.41"
+
+[dev-dependencies]
+tokio = { version = "1.36.0", features = ["io-util", "macros", "rt-multi-thread", "io-std"] }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+wasm-bindgen = "0.2"
+js-sys = "0.3"
+web-sys = { version = "0.3", features = ["WebSocket", "MessageEvent", "Blob"] }