aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-04-12 09:24:19 +0100
committerLibravatar cel 🌸 <cel@bunny.garden>2025-04-12 09:24:19 +0100
commit3d575ec2a4440e7e4597761eab907d63ef91175e (patch)
tree19edf8ad38300304f6bd2f0d81660173b5fee611 /Cargo.toml
parent92f4fd88295cb39bf865e10b0a28cc36acb5276a (diff)
downloadpeanuts-3d575ec2a4440e7e4597761eab907d63ef91175e.tar.gz
peanuts-3d575ec2a4440e7e4597761eab907d63ef91175e.tar.bz2
peanuts-3d575ec2a4440e7e4597761eab907d63ef91175e.zip
feat: move tokio features to dev-dependencies to allow wasm supportwasm
Diffstat (limited to '')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index acec773..3860e60 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,5 +13,9 @@ futures = "0.3.30"
futures-util = { version = "0.3.31", features = ["sink"] }
nom = "7.1.3"
thiserror = "2.0.11"
-tokio = { version = "1.36.0", features = ["io-util", "net", "io-std", "full"] }
+tokio = { version = "1.36.0", features = ["io-util"] }
tracing = "0.1.41"
+
+[dev-dependencies]
+tokio = { version = "1.36.0", features = ["io-util", "macros", "rt-multi-thread", "io-std"] }
+