aboutsummaryrefslogtreecommitdiffstats
path: root/luz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--luz/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/luz/Cargo.toml b/luz/Cargo.toml
index 709bc00..51c6936 100644
--- a/luz/Cargo.toml
+++ b/luz/Cargo.toml
@@ -21,7 +21,7 @@ rsasl = { version = "2.0.1", default_features = false, features = [
"config_builder",
"scram-sha-1",
] }
-tokio = { version = "1.28", features = [] }
+tokio = { workspace = true, features = ["io-util"] }
tracing = "0.1.40"
try_map = "0.3.1"
stanza = { version = "0.1.0", path = "../stanza" }
@@ -35,6 +35,7 @@ pin-project = "1.1.7"
thiserror = "2.0.11"
[target.'cfg(target_arch = "wasm32")'.dependencies]
+tokio = { workspace = true, features = ["io-util", "sync"] }
uuid = { version = "1.13.1", features = ["js", "v4"] }
getrandom = { version = "0.2.15", features = ["js"] }
stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_7395"] }
@@ -42,13 +43,14 @@ web-sys = { version = "0.3", features = ["Request", "WebSocket"] }
wasm-bindgen = "0.2"
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+tokio = { workspace = true, features = ["io-util", "sync"] }
tokio-native-tls = "0.3.1"
trust-dns-resolver = "0.22.0"
[dev-dependencies]
tracing-wasm = "0.2.1"
wasm-bindgen-test = "0.3.0"
-tokio = { version = "1.28", features = ["macros", "rt", "time"] }
+tokio = { workspace = true, features = ["macros", "rt", "time"] }
test-log = { version = "0.2", features = ["trace"] }
env_logger = "*"
tracing-subscriber = { version = "0.3", default-features = false, features = [