aboutsummaryrefslogtreecommitdiffstats
path: root/luz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--luz/Cargo.toml14
1 files changed, 10 insertions, 4 deletions
diff --git a/luz/Cargo.toml b/luz/Cargo.toml
index 0a7f86e..d7207ca 100644
--- a/luz/Cargo.toml
+++ b/luz/Cargo.toml
@@ -10,7 +10,7 @@ edition = "2021"
async-recursion = "1.0.4"
async-trait = "0.1.68"
lazy_static = "1.4.0"
-nanoid = "0.4.0"
+uuid = { version = "1.13.1", features = ["v4"] }
# TODO: remove unneeded features and dependencies
rsasl = { version = "2.0.1", default_features = false, features = [
"provider_base64",
@@ -18,10 +18,8 @@ rsasl = { version = "2.0.1", default_features = false, features = [
"config_builder",
"scram-sha-1",
] }
-tokio = { version = "1.28", features = ["full"] }
-tokio-native-tls = "0.3.1"
+tokio = { version = "1.28", features = [] }
tracing = "0.1.40"
-trust-dns-resolver = "0.22.0"
try_map = "0.3.1"
stanza = { version = "0.1.0", path = "../stanza" }
peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
@@ -32,6 +30,14 @@ pin-project-lite = "0.2.15"
pin-project = "1.1.7"
thiserror = "2.0.11"
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+uuid = { version = "1.13.1", features = ["js", "v4"] }
+getrandom = { version = "0.2.15", features = ["js"] }
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+tokio-native-tls = "0.3.1"
+trust-dns-resolver = "0.22.0"
+
[dev-dependencies]
test-log = { version = "0.2", features = ["trace"] }
env_logger = "*"