aboutsummaryrefslogtreecommitdiffstats
path: root/luz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--luz/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/luz/Cargo.toml b/luz/Cargo.toml
index d7207ca..709bc00 100644
--- a/luz/Cargo.toml
+++ b/luz/Cargo.toml
@@ -4,6 +4,9 @@ authors = ["cel <cel@bunny.garden>"]
version = "0.1.0"
edition = "2021"
+[lib]
+crate-type = ["cdylib", "rlib"]
+
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
@@ -23,6 +26,7 @@ tracing = "0.1.40"
try_map = "0.3.1"
stanza = { version = "0.1.0", path = "../stanza" }
peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
+# peanuts = { version = "0.1.0", path = "../../peanuts" }
jid = { version = "0.1.0", path = "../jid" }
futures = "0.3.31"
take_mut = "0.2.2"
@@ -33,12 +37,18 @@ thiserror = "2.0.11"
[target.'cfg(target_arch = "wasm32")'.dependencies]
uuid = { version = "1.13.1", features = ["js", "v4"] }
getrandom = { version = "0.2.15", features = ["js"] }
+stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_7395"] }
+web-sys = { version = "0.3", features = ["Request", "WebSocket"] }
+wasm-bindgen = "0.2"
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
tokio-native-tls = "0.3.1"
trust-dns-resolver = "0.22.0"
[dev-dependencies]
+tracing-wasm = "0.2.1"
+wasm-bindgen-test = "0.3.0"
+tokio = { version = "1.28", features = ["macros", "rt", "time"] }
test-log = { version = "0.2", features = ["trace"] }
env_logger = "*"
tracing-subscriber = { version = "0.3", default-features = false, features = [