aboutsummaryrefslogtreecommitdiffstats
path: root/lampada/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--lampada/Cargo.toml11
1 files changed, 9 insertions, 2 deletions
diff --git a/lampada/Cargo.toml b/lampada/Cargo.toml
index c68f9c6..22f133d 100644
--- a/lampada/Cargo.toml
+++ b/lampada/Cargo.toml
@@ -7,8 +7,15 @@ edition = "2021"
futures = "0.3.31"
luz = { version = "0.1.0", path = "../luz" }
peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
-jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
+jid = { version = "0.1.0", path = "../jid" }
stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0203"] }
-tokio = "1.42.0"
+tokio = { version = "1.42.0", features = ["macros"] }
tracing = "0.1.41"
thiserror = "2.0.11"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+tokio = { version = "1.42.0", features = ["macros", "rt", "time"] }
+wasm-bindgen-futures = "0.4"
+
+# [target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+# tokio = { version = "1.42.0", features = ["rt-multi-thread"] }