aboutsummaryrefslogtreecommitdiffstats
path: root/lampada/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--lampada/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/lampada/Cargo.toml b/lampada/Cargo.toml
index 22f133d..090aa9f 100644
--- a/lampada/Cargo.toml
+++ b/lampada/Cargo.toml
@@ -9,13 +9,13 @@ luz = { version = "0.1.0", path = "../luz" }
peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
jid = { version = "0.1.0", path = "../jid" }
stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0203"] }
-tokio = { version = "1.42.0", features = ["macros"] }
+tokio = { workspace = true, features = ["macros", "sync"] }
tracing = "0.1.41"
thiserror = "2.0.11"
[target.'cfg(target_arch = "wasm32")'.dependencies]
-tokio = { version = "1.42.0", features = ["macros", "rt", "time"] }
-wasm-bindgen-futures = "0.4"
+tokio = { workspace = true, features = ["macros", "rt", "time", "sync"] }
+tokio_with_wasm = { version = "0.8.2", features = ["macros", "rt", "time", "sync"] }
# [target.'cfg(not(target_arch = "wasm32"))'.dependencies]
# tokio = { version = "1.42.0", features = ["rt-multi-thread"] }