aboutsummaryrefslogtreecommitdiffstats
path: root/jid/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--jid/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/jid/Cargo.toml b/jid/Cargo.toml
index d5983ea..57421ef 100644
--- a/jid/Cargo.toml
+++ b/jid/Cargo.toml
@@ -6,5 +6,9 @@ edition = "2021"
[features]
sqlx = ["dep:sqlx"]
-[dependencies]
-sqlx = { version = "0.8.3", features = ["sqlite"], optional = true }
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+# sqlx = { version = "0.8.3", features = ["sqlite"], optional = true }
+sqlx = { path = "../../remote/sqlx", features = ["sqlite"], optional = true }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+sqlx = { path = "../../remote/sqlx", features = ["sqlite-precompiled-wasm"], optional = true }