aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--filamento/Cargo.toml16
1 files changed, 12 insertions, 4 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
index 66cbc31..cc05288 100644
--- a/filamento/Cargo.toml
+++ b/filamento/Cargo.toml
@@ -3,16 +3,19 @@ name = "filamento"
version = "0.1.0"
edition = "2024"
+[features]
+serde = ["dep:serde", "jid/serde", "uuid/serde", "chrono/serde", "lampada/serde"]
+
[dependencies]
-futures = "0.3.31"
+futures = "0.3.30"
lampada = { version = "0.1.0", path = "../lampada" }
tokio = { workspace = true }
thiserror = "2.0.11"
stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128", "xep_0115", "xep_0084"] }
# TODO: re-export jid?
-jid = { version = "0.1.0", path = "../jid" }
+jid = { version = "0.1.0", path = "../jid", features = ["rusqlite"] }
uuid = { version = "1.13.1", features = ["v4"] }
-rusqlite = { git = "https://github.com/Spxg/rusqlite.git" }
+rusqlite = { git = "https://github.com/Spxg/rusqlite.git", branch = "wasm-demo", features = ["uuid", "chrono"] }
tracing = "0.1.41"
chrono = "0.4.40"
sha2 = "0.10.8"
@@ -21,11 +24,16 @@ base64 = "0.22.1"
sha1 = "0.10.6"
image = "0.25.6"
hex = "0.4.3"
+serde = { version = "1.0.219", features = ["derive"], optional = true }
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-tokio = { workspace = true, features = ["sync", "time", "rt", "fs"] }
+tokio = { workspace = true, features = ["sync", "time", "rt", "fs", "io-std"] }
[target.'cfg(target_arch = "wasm32")'.dependencies]
+jid = { version = "0.1.0", path = "../jid", features = ["rusqlite"] }
+wasm-bindgen = "0.2"
+wasm-bindgen-futures = "0.4"
+rusqlite = { git = "https://github.com/Spxg/rusqlite.git", branch = "wasm-demo", features = ["uuid", "chrono", "precompiled-wasm"] }
tokio = { workspace = true, features = ["sync", "time", "rt"] }
tokio_with_wasm = { version = "0.8.2", features = ["sync", "time", "rt"] }