aboutsummaryrefslogtreecommitdiffstats
path: root/lampada/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-04-13 16:45:53 +0100
committerLibravatar cel 🌸 <cel@bunny.garden>2025-04-13 16:45:53 +0100
commitcf51dcf052af89f8742d887bde2c93d735309bdd (patch)
treefb7d8b7a313511de845db6cfd186f3b87c472154 /lampada/Cargo.toml
parent603777c5f4b3f8248378af6fe5af65b54e0f120e (diff)
downloadluz-cf51dcf052af89f8742d887bde2c93d735309bdd.tar.gz
luz-cf51dcf052af89f8742d887bde2c93d735309bdd.tar.bz2
luz-cf51dcf052af89f8742d887bde2c93d735309bdd.zip
feat(lampada): wasm + websockets support
Diffstat (limited to '')
-rw-r--r--lampada/Cargo.toml11
1 files changed, 9 insertions, 2 deletions
diff --git a/lampada/Cargo.toml b/lampada/Cargo.toml
index c68f9c6..22f133d 100644
--- a/lampada/Cargo.toml
+++ b/lampada/Cargo.toml
@@ -7,8 +7,15 @@ edition = "2021"
futures = "0.3.31"
luz = { version = "0.1.0", path = "../luz" }
peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
-jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
+jid = { version = "0.1.0", path = "../jid" }
stanza = { version = "0.1.0", path = "../stanza", features = ["xep_0203"] }
-tokio = "1.42.0"
+tokio = { version = "1.42.0", features = ["macros"] }
tracing = "0.1.41"
thiserror = "2.0.11"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+tokio = { version = "1.42.0", features = ["macros", "rt", "time"] }
+wasm-bindgen-futures = "0.4"
+
+# [target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+# tokio = { version = "1.42.0", features = ["rt-multi-thread"] }