aboutsummaryrefslogtreecommitdiffstats
path: root/jid/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-04-17 11:03:51 +0100
committerLibravatar cel 🌸 <cel@bunny.garden>2025-04-17 11:03:51 +0100
commitb9d75f38743113c054be3d97af36bdd2a7dd0d69 (patch)
tree537623664010d26d5f2574e2d51d03f8c25e08ac /jid/Cargo.toml
parentcf51dcf052af89f8742d887bde2c93d735309bdd (diff)
downloadluz-b9d75f38743113c054be3d97af36bdd2a7dd0d69.tar.gz
luz-b9d75f38743113c054be3d97af36bdd2a7dd0d69.tar.bz2
luz-b9d75f38743113c054be3d97af36bdd2a7dd0d69.zip
feat(filamento): compiles on wasm
Diffstat (limited to '')
-rw-r--r--jid/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/jid/Cargo.toml b/jid/Cargo.toml
index d5983ea..57421ef 100644
--- a/jid/Cargo.toml
+++ b/jid/Cargo.toml
@@ -6,5 +6,9 @@ edition = "2021"
[features]
sqlx = ["dep:sqlx"]
-[dependencies]
-sqlx = { version = "0.8.3", features = ["sqlite"], optional = true }
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+# sqlx = { version = "0.8.3", features = ["sqlite"], optional = true }
+sqlx = { path = "../../remote/sqlx", features = ["sqlite"], optional = true }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+sqlx = { path = "../../remote/sqlx", features = ["sqlite-precompiled-wasm"], optional = true }