aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-04-17 17:30:22 +0100
committerLibravatar cel 🌸 <cel@bunny.garden>2025-04-17 17:30:22 +0100
commit61b755c890dcaa66daa35942ca87cc00269b0fe9 (patch)
tree36190a844cfef474d5e11fe473db462bb4a4d135 /filamento/Cargo.toml
parent26d0ee51e232b793bc83ba565c0e9ab820d8d0db (diff)
downloadluz-61b755c890dcaa66daa35942ca87cc00269b0fe9.tar.gz
luz-61b755c890dcaa66daa35942ca87cc00269b0fe9.tar.bz2
luz-61b755c890dcaa66daa35942ca87cc00269b0fe9.zip
feat(filamento): full wasm support by switching to rusqlite
Diffstat (limited to 'filamento/Cargo.toml')
-rw-r--r--filamento/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
index 66cbc31..1519f58 100644
--- a/filamento/Cargo.toml
+++ b/filamento/Cargo.toml
@@ -10,9 +10,9 @@ tokio = { workspace = true }
thiserror = "2.0.11"
stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128", "xep_0115", "xep_0084"] }
# TODO: re-export jid?
-jid = { version = "0.1.0", path = "../jid" }
+jid = { version = "0.1.0", path = "../jid", features = ["rusqlite"] }
uuid = { version = "1.13.1", features = ["v4"] }
-rusqlite = { git = "https://github.com/Spxg/rusqlite.git" }
+rusqlite = { git = "https://github.com/Spxg/rusqlite.git", branch = "wasm-demo", features = ["uuid", "chrono"] }
tracing = "0.1.41"
chrono = "0.4.40"
sha2 = "0.10.8"
@@ -26,6 +26,7 @@ hex = "0.4.3"
tokio = { workspace = true, features = ["sync", "time", "rt", "fs"] }
[target.'cfg(target_arch = "wasm32")'.dependencies]
+rusqlite = { git = "https://github.com/Spxg/rusqlite.git", branch = "wasm-demo", features = ["uuid", "chrono", "precompiled-wasm"] }
tokio = { workspace = true, features = ["sync", "time", "rt"] }
tokio_with_wasm = { version = "0.8.2", features = ["sync", "time", "rt"] }