aboutsummaryrefslogtreecommitdiffstats
path: root/filamento/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar cel 🌸 <cel@bunny.garden>2025-04-17 11:03:51 +0100
committerLibravatar cel 🌸 <cel@bunny.garden>2025-04-17 11:03:51 +0100
commitb9d75f38743113c054be3d97af36bdd2a7dd0d69 (patch)
tree537623664010d26d5f2574e2d51d03f8c25e08ac /filamento/Cargo.toml
parentcf51dcf052af89f8742d887bde2c93d735309bdd (diff)
downloadluz-b9d75f38743113c054be3d97af36bdd2a7dd0d69.tar.gz
luz-b9d75f38743113c054be3d97af36bdd2a7dd0d69.tar.bz2
luz-b9d75f38743113c054be3d97af36bdd2a7dd0d69.zip
feat(filamento): compiles on wasm
Diffstat (limited to '')
-rw-r--r--filamento/Cargo.toml18
1 files changed, 16 insertions, 2 deletions
diff --git a/filamento/Cargo.toml b/filamento/Cargo.toml
index 91b7e91..4c36c95 100644
--- a/filamento/Cargo.toml
+++ b/filamento/Cargo.toml
@@ -6,10 +6,10 @@ edition = "2024"
[dependencies]
futures = "0.3.31"
lampada = { version = "0.1.0", path = "../lampada" }
-tokio = "1.42.0"
+tokio = { workspace = true }
+# tokio = "1.42.0"
thiserror = "2.0.11"
stanza = { version = "0.1.0", path = "../stanza", features = ["rfc_6121", "xep_0203", "xep_0030", "xep_0060", "xep_0172", "xep_0390", "xep_0128", "xep_0115", "xep_0084"] }
-sqlx = { version = "0.8.3", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
# TODO: re-export jid?
jid = { version = "0.1.0", path = "../jid", features = ["sqlx"] }
uuid = { version = "1.13.1", features = ["v4"] }
@@ -22,9 +22,23 @@ sha1 = "0.10.6"
image = "0.25.6"
hex = "0.4.3"
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+tokio = { workspace = true, features = ["sync", "time", "rt", "fs"] }
+sqlx = { path = "../../remote/sqlx", features = ["sqlite", "runtime-tokio", "uuid", "chrono"] }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+tokio = { workspace = true, features = ["sync", "time", "rt"] }
+# tokio = { version = "1.44.3", features = [] }
+sqlx = { path = "../../remote/sqlx", features = ["sqlite-precompiled-wasm", "runtime-tokio", "uuid", "chrono"] }
+tokio_with_wasm = { version = "0.8.2", features = ["sync", "time", "rt"] }
+# wasm-bindgen-futures = "0.4"
+
[dev-dependencies]
tracing-subscriber = "0.3.19"
peanuts = { version = "0.1.0", git = "https://bunny.garden/peanuts" }
+tracing-wasm = "0.2.1"
+tokio_with_wasm = { version = "0.8.2", features = ["sync", "time", "rt"] }
+wasm-bindgen-test = "0.3.0"
[[example]]
name = "example"