diff options
author | Kyle McCarthy <km@kylemccarthy.io> | 2023-01-03 04:52:22 -0600 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-01-03 11:52:22 +0100 |
commit | 2045b0bfc467efeb605aad7d8297a1fa1fc3e0e9 (patch) | |
tree | 7dab2abbf993e04b269fbab3191d7bfa7b7663ae /Cargo.toml | |
parent | af202d3f0ea24e0a957b02a6f9fb23c6c3b4afe7 (diff) | |
download | markdown-rs-2045b0bfc467efeb605aad7d8297a1fa1fc3e0e9.tar.gz markdown-rs-2045b0bfc467efeb605aad7d8297a1fa1fc3e0e9.tar.bz2 markdown-rs-2045b0bfc467efeb605aad7d8297a1fa1fc3e0e9.zip |
Add support for serializing trees as JSON
This adds support for serializing the mdast syntax tree as JSON,
with serde, through a feature.
Closes GH-10.
Related-to GH-30.
Closes GH-37.
Diffstat (limited to '')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -17,9 +17,15 @@ name = "bench" path = "benches/bench.rs" harness = false +[features] +default = ["json"] +json = ["dep:serde", "dep:serde_json"] + [dependencies] log = "0.4" unicode-id = { version = "0.3", features = ["no_std"] } +serde = { version = "1.0", optional = true } +serde_json = { version = "1.0", optional = true } [dev-dependencies] env_logger = "0.10" |