From 63933e26d2ffd530fc1d8c9a7d7b94927c0e8cc8 Mon Sep 17 00:00:00 2001
From: Clark Moody <clark@clarkmoody.com>
Date: Tue, 31 Mar 2020 12:11:37 -0500
Subject: Add `palette` dependency behind "colors" feature flag

---
 Cargo.toml | 3 +++
 1 file changed, 3 insertions(+)

(limited to 'Cargo.toml')

diff --git a/Cargo.toml b/Cargo.toml
index 9c52ea8f..7f6e1f0f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,6 +24,8 @@ debug = ["iced_winit/debug"]
 tokio = ["iced_futures/tokio"]
 # Enables `async-std` as the `executor::Default` on native platforms
 async-std = ["iced_futures/async-std"]
+# Enables advanced color conversion via `palette`
+colors = ["iced_core/colors"]
 
 [badges]
 maintenance = { status = "actively-developed" }
@@ -57,6 +59,7 @@ members = [
 ]
 
 [dependencies]
+iced_core = { version = "0.1", path = "core" }
 iced_futures = { version = "0.1", path = "futures" }
 
 [target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-- 
cgit 


From 7b15e4b0e29c64d53a00fbe6709ff2069630fec5 Mon Sep 17 00:00:00 2001
From: Clark Moody <clark@clarkmoody.com>
Date: Tue, 31 Mar 2020 16:44:02 -0500
Subject: Feature name colors -> palette

---
 Cargo.toml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'Cargo.toml')

diff --git a/Cargo.toml b/Cargo.toml
index 7f6e1f0f..9b88f9ec 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,7 +25,7 @@ tokio = ["iced_futures/tokio"]
 # Enables `async-std` as the `executor::Default` on native platforms
 async-std = ["iced_futures/async-std"]
 # Enables advanced color conversion via `palette`
-colors = ["iced_core/colors"]
+palette = ["iced_core/palette"]
 
 [badges]
 maintenance = { status = "actively-developed" }
-- 
cgit 


From 664a63a4b8c1b0b945ca45b1181ead040a12fa73 Mon Sep 17 00:00:00 2001
From: Clark Moody <clark@clarkmoody.com>
Date: Thu, 2 Apr 2020 17:52:21 -0500
Subject: Add example program: color palette

Sliders for many color spaces update as any other sliders are moved
around. Color is space is clamped to sRGB, so Lab and Lch color spaces
cannot be fully expressed.

TODO:
- Real-time manipulation of base color to create a color scheme.
- Show slider value under each slider
- Show output values in text boxes for each color space
---
 Cargo.toml | 1 +
 1 file changed, 1 insertion(+)

(limited to 'Cargo.toml')

diff --git a/Cargo.toml b/Cargo.toml
index 9b88f9ec..8f0a95c3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -41,6 +41,7 @@ members = [
     "winit",
     "examples/bezier_tool",
     "examples/clock",
+    "examples/color_palette",
     "examples/counter",
     "examples/custom_widget",
     "examples/download_progress",
-- 
cgit 


From 6b18e78e535d50f648bd5ba739eb29b3c76a7965 Mon Sep 17 00:00:00 2001
From: Clark Moody <clark@clarkmoody.com>
Date: Wed, 8 Apr 2020 17:45:54 -0500
Subject: Use canvas to draw color palette for example

---
 Cargo.toml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'Cargo.toml')

diff --git a/Cargo.toml b/Cargo.toml
index 8f0a95c3..206409bf 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -60,7 +60,7 @@ members = [
 ]
 
 [dependencies]
-iced_core = { version = "0.1", path = "core" }
+iced_core = { version = "0.2", path = "core" }
 iced_futures = { version = "0.1", path = "futures" }
 
 [target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-- 
cgit