summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml18
1 files changed, 15 insertions, 3 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index 2a33255d..63df1d63 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -6,12 +6,24 @@ edition = "2018"
description = "A winit runtime for Iced"
license = "MIT"
repository = "https://github.com/hecrj/iced"
+documentation = "https://docs.rs/iced_winit"
+keywords = ["gui", "ui", "graphics", "interface", "widgets"]
+categories = ["gui"]
[features]
debug = []
[dependencies]
-iced_native = { version = "0.1.0-alpha", path = "../native" }
-winit = { version = "0.20.0-alpha3", git = "https://github.com/rust-windowing/winit", rev = "709808eb4e69044705fcb214bcc30556db761405"}
-futures = { version = "0.3", features = ["thread-pool"] }
+winit = "0.21"
log = "0.4"
+
+[dependencies.iced_native]
+version = "0.1.0-alpha"
+path = "../native"
+
+[dependencies.window_clipboard]
+git = "https://github.com/hecrj/window_clipboard"
+rev = "22c6dd6c04cd05d528029b50a30c56417cd4bebf"
+
+[target.'cfg(target_os = "windows")'.dependencies.winapi]
+version = "0.3.6"