summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index bfcfacbc..f7232248 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -2,7 +2,7 @@
name = "iced_winit"
version = "0.3.0"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2018"
+edition = "2021"
description = "A winit runtime for Iced"
license = "MIT"
repository = "https://github.com/hecrj/iced"
@@ -37,3 +37,7 @@ path = "../futures"
[target.'cfg(target_os = "windows")'.dependencies.winapi]
version = "0.3.6"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies.web-sys]
+version = "0.3"
+features = ["Document", "Window"]