summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml14
1 files changed, 10 insertions, 4 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index 1bf63804..58e13b3e 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced_winit"
-version = "0.8.0"
+version = "0.9.1"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2021"
description = "A winit runtime for Iced"
@@ -11,11 +11,16 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
[features]
+default = ["x11", "wayland", "wayland-dlopen", "wayland-csd-adwaita"]
trace = ["tracing", "tracing-core", "tracing-subscriber"]
chrome-trace = ["trace", "tracing-chrome"]
debug = ["iced_runtime/debug"]
system = ["sysinfo"]
application = []
+x11 = ["winit/x11"]
+wayland = ["winit/wayland"]
+wayland-dlopen = ["winit/wayland-dlopen"]
+wayland-csd-adwaita = ["winit/wayland-csd-adwaita"]
[dependencies]
window_clipboard = "0.2"
@@ -26,17 +31,18 @@ thiserror = "1.0"
version = "0.27"
git = "https://github.com/iced-rs/winit.git"
rev = "940457522e9fb9f5dac228b0ecfafe0138b4048c"
+default-features = false
[dependencies.iced_runtime]
-version = "0.9"
+version = "0.1"
path = "../runtime"
[dependencies.iced_graphics]
-version = "0.7"
+version = "0.8"
path = "../graphics"
[dependencies.iced_style]
-version = "0.7"
+version = "0.8"
path = "../style"
[dependencies.tracing]