summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml90
1 files changed, 40 insertions, 50 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 49c62673..97594f1a 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -1,11 +1,18 @@
[package]
name = "iced_wgpu"
-version = "0.11.1"
-authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2021"
-description = "A wgpu renderer for Iced"
-license = "MIT AND OFL-1.1"
-repository = "https://github.com/iced-rs/iced"
+description = "A renderer for iced on top of wgpu"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--cfg", "docsrs"]
+all-features = true
[features]
geometry = ["iced_graphics/geometry", "lyon"]
@@ -15,47 +22,30 @@ web-colors = ["iced_graphics/web-colors"]
webgl = ["wgpu/webgl"]
[dependencies]
-wgpu = "0.17"
-glyphon = { git = "https://github.com/grovesNL/glyphon.git", rev = "20f0f8fa80e0d0df4c63634ce9176fa489546ca9" }
-raw-window-handle = "0.5"
-guillotiere = "0.6"
-futures = "0.3"
-bitflags = "1.2"
-once_cell = "1.0"
-rustc-hash = "1.1"
-log = "0.4"
-
-[dependencies.twox-hash]
-version = "1.6"
-default-features = false
-
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.twox-hash]
-version = "1.6.1"
-features = ["std"]
-
-[dependencies.bytemuck]
-version = "1.9"
-features = ["derive"]
-
-[dependencies.iced_graphics]
-version = "0.9"
-path = "../graphics"
-
-[dependencies.glam]
-version = "0.24"
-
-[dependencies.lyon]
-version = "1.0"
-optional = true
-
-[dependencies.resvg]
-version = "0.35"
-optional = true
-
-[dependencies.tracing]
-version = "0.1.6"
-optional = true
-
-[package.metadata.docs.rs]
-rustdoc-args = ["--cfg", "docsrs"]
-all-features = true
+iced_graphics.workspace = true
+
+bitflags.workspace = true
+bytemuck.workspace = true
+futures.workspace = true
+glam.workspace = true
+glyphon.workspace = true
+guillotiere.workspace = true
+log.workspace = true
+once_cell.workspace = true
+raw-window-handle.workspace = true
+rustc-hash.workspace = true
+twox-hash.workspace = true
+wgpu.workspace = true
+
+lyon.workspace = true
+lyon.optional = true
+
+resvg.workspace = true
+resvg.optional = true
+
+tracing.workspace = true
+tracing.optional = true
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+twox-hash.workspace = true
+twox-hash.features = ["std"]