summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml24
1 files changed, 21 insertions, 3 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index f008a99c..6c75af7b 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -4,16 +4,34 @@ version = "0.1.0"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2018"
description = "A wgpu renderer for Iced"
-license = "MIT"
+license = "MIT AND OFL-1.1"
repository = "https://github.com/hecrj/iced"
+[features]
+svg = ["resvg"]
+canvas = ["lyon"]
+
[dependencies]
iced_native = { version = "0.1.0", path = "../native" }
+iced_style = { version = "0.1.0-alpha", path = "../style" }
wgpu = "0.4"
+wgpu_glyph = "0.7"
glyph_brush = "0.6"
-wgpu_glyph = "0.6"
raw-window-handle = "0.3"
-image = "0.22"
glam = "0.8"
font-kit = "0.4"
log = "0.4"
+guillotiere = "0.4"
+
+[dependencies.image]
+version = "0.22"
+optional = true
+
+[dependencies.resvg]
+version = "0.8"
+features = ["raqote-backend"]
+optional = true
+
+[dependencies.lyon]
+version = "0.15"
+optional = true