summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml19
1 files changed, 9 insertions, 10 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 9e80a76d..4cdd6c68 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -21,8 +21,7 @@ bmp = ["iced_graphics/bmp"]
hdr = ["iced_graphics/hdr"]
dds = ["iced_graphics/dds"]
farbfeld = ["iced_graphics/farbfeld"]
-canvas = ["iced_graphics/canvas"]
-qr_code = ["iced_graphics/qr_code"]
+geometry = ["iced_graphics/geometry", "lyon"]
spirv = ["wgpu/spirv"]
webgl = ["wgpu/webgl"]
@@ -49,10 +48,6 @@ features = ["std"]
version = "1.9"
features = ["derive"]
-[dependencies.iced_native]
-version = "0.9"
-path = "../native"
-
[dependencies.iced_graphics]
version = "0.7"
path = "../graphics"
@@ -62,10 +57,6 @@ version = "0.2"
git = "https://github.com/hecrj/glyphon.git"
rev = "810bc979f9005e2bd343b72b980e57e46174283f"
-[dependencies.tracing]
-version = "0.1.6"
-optional = true
-
[dependencies.encase]
version = "0.3.0"
features = ["glam"]
@@ -73,6 +64,14 @@ features = ["glam"]
[dependencies.glam]
version = "0.21.3"
+[dependencies.lyon]
+version = "1.0"
+optional = true
+
+[dependencies.tracing]
+version = "0.1.6"
+optional = true
+
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
all-features = true