summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml69
1 files changed, 35 insertions, 34 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index f1e22cf6..22cfad55 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced_wgpu"
-version = "0.9.0"
+version = "0.10.0"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2021"
description = "A wgpu renderer for Iced"
@@ -8,58 +8,59 @@ license = "MIT AND OFL-1.1"
repository = "https://github.com/iced-rs/iced"
[features]
-svg = ["iced_graphics/svg"]
+geometry = ["iced_graphics/geometry", "lyon"]
image = ["iced_graphics/image"]
-png = ["iced_graphics/png"]
-jpeg = ["iced_graphics/jpeg"]
-jpeg_rayon = ["iced_graphics/jpeg_rayon"]
-gif = ["iced_graphics/gif"]
-webp = ["iced_graphics/webp"]
-pnm = ["iced_graphics/pnm"]
-ico = ["iced_graphics/ico"]
-bmp = ["iced_graphics/bmp"]
-hdr = ["iced_graphics/hdr"]
-dds = ["iced_graphics/dds"]
-farbfeld = ["iced_graphics/farbfeld"]
-canvas = ["iced_graphics/canvas"]
-qr_code = ["iced_graphics/qr_code"]
-default_system_font = ["iced_graphics/font-source"]
-spirv = ["wgpu/spirv"]
-webgl = ["wgpu/webgl"]
+svg = ["resvg"]
+web-colors = ["iced_graphics/web-colors"]
[dependencies]
-wgpu = "0.14"
-wgpu_glyph = "0.18"
-glyph_brush = "0.7"
+wgpu = "0.16"
raw-window-handle = "0.5"
log = "0.4"
guillotiere = "0.6"
futures = "0.3"
bitflags = "1.2"
+once_cell = "1.0"
+rustc-hash = "1.1"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+wgpu = { version = "0.16", features = ["webgl"] }
+
+[dependencies.twox-hash]
+version = "1.6"
+default-features = false
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.twox-hash]
+version = "1.6.1"
+features = ["std"]
[dependencies.bytemuck]
version = "1.9"
features = ["derive"]
-[dependencies.iced_native]
-version = "0.9"
-path = "../native"
-
[dependencies.iced_graphics]
-version = "0.7"
+version = "0.8"
path = "../graphics"
-features = ["font-fallback", "font-icons"]
-[dependencies.tracing]
-version = "0.1.6"
+[dependencies.glyphon]
+version = "0.2"
+git = "https://github.com/hecrj/glyphon.git"
+rev = "8324f20158a62f8520bad4ed09f6aa5552f8f2a6"
+
+[dependencies.glam]
+version = "0.24"
+
+[dependencies.lyon]
+version = "1.0"
optional = true
-[dependencies.encase]
-version = "0.3.0"
-features = ["glam"]
+[dependencies.resvg]
+version = "0.35"
+optional = true
-[dependencies.glam]
-version = "0.21.3"
+[dependencies.tracing]
+version = "0.1.6"
+optional = true
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]