summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml36
1 files changed, 17 insertions, 19 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 612af1ed..5f4699a8 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced_wgpu"
-version = "0.2.2"
+version = "0.3.0"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2018"
description = "A wgpu renderer for Iced"
@@ -9,29 +9,31 @@ repository = "https://github.com/hecrj/iced"
[features]
svg = ["resvg"]
-canvas = ["lyon"]
+canvas = ["iced_graphics/canvas"]
+qr_code = ["iced_graphics/qr_code"]
+default_system_font = ["iced_graphics/font-source"]
[dependencies]
-wgpu = "0.5"
-wgpu_glyph = "0.8"
-zerocopy = "0.3"
-glyph_brush = "0.6"
+wgpu = "0.6"
+wgpu_glyph = "0.10"
+glyph_brush = "0.7"
raw-window-handle = "0.3"
-glam = "0.8"
-font-kit = "0.6"
log = "0.4"
-guillotiere = "0.5"
-# Pin `gfx-memory` until https://github.com/gfx-rs/wgpu-rs/issues/261 is
-# resolved
-gfx-memory = "=0.1.1"
+guillotiere = "0.6"
+futures = "0.3"
+
+[dependencies.bytemuck]
+version = "1.4"
+features = ["derive"]
[dependencies.iced_native]
-version = "0.2"
+version = "0.3"
path = "../native"
-[dependencies.iced_style]
+[dependencies.iced_graphics]
version = "0.1"
-path = "../style"
+path = "../graphics"
+features = ["font-fallback", "font-icons"]
[dependencies.image]
version = "0.23"
@@ -42,10 +44,6 @@ version = "0.9"
features = ["raqote-backend"]
optional = true
-[dependencies.lyon]
-version = "0.15"
-optional = true
-
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
all-features = true